aboutsummaryrefslogtreecommitdiffstats
path: root/recipes
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-11-10 22:16:43 +0100
committerKoen Kooi <koen@openembedded.org>2009-11-10 22:16:43 +0100
commit09ebc69351c7e28b57ded8c95ee0d27b065e36a1 (patch)
treed9ee3ecdf3e7f42cf5cbfa120355f405656ec23a /recipes
parentc028070df436ea6b94395e776c7fd7266b64e0a6 (diff)
downloadopenembedded-09ebc69351c7e28b57ded8c95ee0d27b065e36a1.tar.gz
perl: complete config.sh fix
Diffstat (limited to 'recipes')
-rw-r--r--recipes/perl/perl-native_5.8.8.bb2
-rw-r--r--recipes/perl/perl.inc4
-rw-r--r--recipes/perl/perl_5.8.8.bb4
3 files changed, 5 insertions, 5 deletions
diff --git a/recipes/perl/perl-native_5.8.8.bb b/recipes/perl/perl-native_5.8.8.bb
index cac474edc4..ba05406eb0 100644
--- a/recipes/perl/perl-native_5.8.8.bb
+++ b/recipes/perl/perl-native_5.8.8.bb
@@ -88,7 +88,7 @@ do_stage_append() {
}
do_stage_append_nylon() {
# get rid of definitions not supported by the gcc version we use for nylon...
- for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR_HOST}/perl/config.sh; do
+ for i in ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy.pl ${STAGING_DIR}/${HOST_SYS}/perl/config.sh; do
perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
done
}
diff --git a/recipes/perl/perl.inc b/recipes/perl/perl.inc
index 00184a9dac..9e20ae63e6 100644
--- a/recipes/perl/perl.inc
+++ b/recipes/perl/perl.inc
@@ -36,8 +36,8 @@ do_install() {
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl/
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl/
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
}
PACKAGES_DYNAMIC = "perl-module-*"
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 2508719736..35fcc83ccc 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -141,12 +141,12 @@ do_install() {
fi
}
do_stage() {
- install -d ${STAGING_DIR_HOST}/perl \
+ install -d ${STAGING_DIR}/${HOST_SYS}/perl \
${STAGING_LIBDIR_NATIVE}/perl/${PV} \
${STAGING_LIBDIR}/perl/${PV}/CORE \
${STAGING_DATADIR}/perl/${PV}/ExtUtils
# target config, used by cpan.bbclass to extract version information
- install config.sh ${STAGING_DIR_HOST}/perl/
+ install config.sh ${STAGING_DIR}/${HOST_SYS}/perl/
# target configuration, used by native perl when cross-compiling
install lib/Config_heavy.pl ${STAGING_LIBDIR_NATIVE}/perl/${PV}/Config_heavy-target.pl
# target configuration