aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2016-04-07 20:03:00 -0700
committerRobert Yang <liezhi.yang@windriver.com>2016-04-07 20:11:58 -0700
commita9ea8a660f37bbcf917c71360512ab155241114e (patch)
tree3d45bf90e568faa9905d32d0b44414e81365aa5f
parent5ebea1114d54120d5ff5d8a6cd148110d0fda23f (diff)
downloadopenembedded-core-contrib-rbt/rebuild.tar.gz
pbzip2: fix for rebuildrbt/rebuild
Fixed when rebuild pbzip2: make: Nothing to be done for `all' This may cause unexpected errors, for example, when depends libs changed: | pbzip2: error while loading shared libraries: libbz2.so.0: cannot open shared object file: No such file or directory Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-rw-r--r--meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
index b3c5975811..67fb2ef9c5 100644
--- a/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
+++ b/meta/recipes-extended/pbzip2/pbzip2_1.1.13.bb
@@ -22,6 +22,18 @@ do_configure[noexec] = "1"
EXTRA_OEMAKE = "CXX='${CXX} ${CXXFLAGS}' LDFLAGS='${LDFLAGS}'"
+do_compile_prepend() {
+ # Update timestamp to fix rebuild
+ src_files="pbzip2.cpp BZ2StreamScanner.cpp ErrorContext.cpp"
+ for f in $src_files; do
+ if [ -f $f ]; then
+ touch $f
+ else
+ bbwarn "Regular file $f not found"
+ fi
+ done
+}
+
do_install() {
install -d ${D}${bindir}
install -m 0755 pbzip2 ${D}${bindir}/