summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch')
-rw-r--r--meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
new file mode 100644
index 0000000000..6c61b09f65
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/files/fix_shebang_f2py.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Inappropriate [embedded specific]
+
+Avoids using python from the HOSTs native sysroot for f2py,
+uses TARGET env python instead.
+
+Signed-Off-By: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
+
+Index: numpy-1.11.0/numpy/f2py/setup.py
+===================================================================
+--- numpy-1.11.0.orig/numpy/f2py/setup.py
++++ numpy-1.11.0/numpy/f2py/setup.py
+@@ -37,10 +37,13 @@ def _get_f2py_shebang():
+ should be ``#!python`` rather than ``#!`` followed by the contents of
+ ``sys.executable``.
+ """
+- if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
+- 'bdist_rpm')).intersection(sys.argv):
+- return '#!python'
+- return '#!' + sys.executable
++ #if set(('bdist_wheel', 'bdist_egg', 'bdist_wininst',
++ # 'bdist_rpm')).intersection(sys.argv):
++ # return '#!python'
++ #return '#!' + sys.executable
++
++ # On OE, we need to avoid using the HOSTs python-native, we return env python instead
++ return '#!/usr/bin/env python'
+
+
+ def configuration(parent_package='', top_path=None):