aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/lua')
-rw-r--r--recipes/lua/lua5.1_5.1.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/lua/lua5.1_5.1.4.bb b/recipes/lua/lua5.1_5.1.4.bb
index ba2f8b9e50..e3d56fd959 100644
--- a/recipes/lua/lua5.1_5.1.4.bb
+++ b/recipes/lua/lua5.1_5.1.4.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
HOMEPAGE = "http://www.lua.org/"
DEPENDS += "readline"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
file://bitwise_operators.patch \
file://lua5.1.pc \
@@ -20,6 +20,10 @@ SRC_URI_append_linux-uclibceabi = "${UCLIBC_PATCHES}"
TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'"
+do_configure_prepend() {
+ sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
+}
+
do_compile () {
cp ${WORKDIR}/lua5.1.pc ${S}/
oe_runmake linux