aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/lua
diff options
context:
space:
mode:
authorPetr Štetiar <ynezz@true.cz>2010-10-20 16:23:20 -0700
committerKhem Raj <raj.khem@gmail.com>2010-10-20 18:30:24 -0700
commit4292ef191122b77b7d1890b74ab988e8c1f58615 (patch)
tree486d2481919a614cbe2ced3ac731f31417388ce1 /recipes/lua
parentfff62b3b96794ecd2a912eff451949321c382798 (diff)
downloadopenembedded-4292ef191122b77b7d1890b74ab988e8c1f58615.tar.gz
lua5.1: use standard prefix for Lua libraries
In default configuration Lua uses wrong /usr/local/{lib,share} in it's module/script search path. This patch change it to the usage of the standard /usr/{lib,share} directories. Signed-off-by: Petr Štetiar <ynezz@true.cz> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/lua')
-rw-r--r--recipes/lua/lua5.1_5.1.4.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/lua/lua5.1_5.1.4.bb b/recipes/lua/lua5.1_5.1.4.bb
index ba2f8b9e50..e3d56fd959 100644
--- a/recipes/lua/lua5.1_5.1.4.bb
+++ b/recipes/lua/lua5.1_5.1.4.bb
@@ -4,7 +4,7 @@ LICENSE = "MIT"
HOMEPAGE = "http://www.lua.org/"
DEPENDS += "readline"
-PR = "r7"
+PR = "r8"
SRC_URI = "http://www.lua.org/ftp/lua-${PV}.tar.gz \
file://bitwise_operators.patch \
file://lua5.1.pc \
@@ -20,6 +20,10 @@ SRC_URI_append_linux-uclibceabi = "${UCLIBC_PATCHES}"
TARGET_CC_ARCH += " -fPIC ${LDFLAGS}"
EXTRA_OEMAKE = "'CC=${CC} -fPIC' 'MYCFLAGS=${CFLAGS} -DLUA_USE_LINUX -fPIC' MYLDFLAGS='${LDFLAGS}'"
+do_configure_prepend() {
+ sed -i -e s:/usr/local:${prefix}:g src/luaconf.h
+}
+
do_compile () {
cp ${WORKDIR}/lua5.1.pc ${S}/
oe_runmake linux