aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/chillispot/chillispot_0.98.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/chillispot/chillispot_0.98.bb')
-rw-r--r--recipes/chillispot/chillispot_0.98.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/chillispot/chillispot_0.98.bb b/recipes/chillispot/chillispot_0.98.bb
new file mode 100644
index 0000000000..98b123e394
--- /dev/null
+++ b/recipes/chillispot/chillispot_0.98.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "ChilliSpot is an open source captive portal or wireless LAN access point controller. It is used for authenticating users of a wireless LAN."
+HOMEPAGE = "http://www.chillispot.org/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://www.chillispot.org/download/chillispot-${PV}.tar.gz \
+ file://no-ansi.patch;patch=1 \
+ file://init"
+RRECOMMENDS = "kernel-module-tun"
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${sysconfdir} ${D}${sysconfdir}/init.d
+ install ${S}/doc/chilli.conf ${D}${sysconfdir}
+ install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/chillispot
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/chilli.conf"